Wednesday, February 25, 2009

AIX Commands

Command List and Description

COMMAND PARAMETER DESCRIPTION
bootlist -m normal Alters the list of boot devices (or the ordering of these devices in the list available to the system)
bosboot -a

-ad /dev/rnt

-b

Create a boot image on the default boot device

Create a boot image at location and send to tape

cfgmgr
Configures devices by running the programs in /etc/methods directory.
chcons
Redirects the system console to device or file, effective next startup
chdev -l -a Changes a device's characteristics.
chdisp
Changes the display used by the low-function terminal (LFT subsystem.
chfont
Changes the default font selected at boot time.
chfs -a size=+ / Changes attributes of a file system. This one will increase the Filesystem .
chgroup Users=x,y,z Changes attributes for groups.
chlv -n Rename logical volume from olvname to nlvname
chps -s Changes attributes of a paging space.
chpv
Changes the characteristics of a physical volume in a volume group.
chque -q -a’host = x’ Changes the queue name.
chssys
Changes a subsystem definition in the subsystem object class.
chtcb
Changes or queries the trusted computing base attribute of a file.
chtz.
Changes the system time zone information
chuser rlogin=true Changes attributes for the specified user.
chvfs
Changes entries in the /etc/vfs file.
chvg
Sets the characteristics of a volume group.
crfs -v (jfs)

-d

-m

-Ayes

Create a Filesystem on a pre-defined logical volume( which will automount at boot!)
crfs -v (jfs)

-g

-a size=’

-m

-Ayes

Create a Filesystem and its logical volume (uses default lvname)
crvfs
Creates entries in the /etc/vfs file.
exportvg None Export a volume group
grpck -n ALL Verifies the correctness of a group definition.
hvirprt
Changes the attribute values of a virtual printer.
importvg -y

Import a Volume Group onto hdisk x
lpstat
List print queues
lsallq
Lists the names of all configured queues.
lsallqdev
Lists all configured printer and plotter queue device names within a specified queue.
lsattr -El List detailed configuration for a device
lscfg
List all configured devices

-v List in detail

-l scsi* List all scsi IO devices
lsdev -Cc tape List configured tape devices

-Cc disk List configured disks on devices

-C -s scsi -H List all defined scsi devices
lsdisp
Lists the displays currently available on the system.
lsfont
Lists the fonts available for use by the display.
lsfs -l List all filesystems in /etc/filesystems quering the LVM descriptor area and superblocks
lsfs
Displays the characteristics of file systems.
lsgroup ALL Displays the attributes of groups.(checks NIS aswell!)
lsitab -a Lists the records in the /etc/inittab file.
lskbd
Lists the keyboard maps currently available to the low-function terminal (LFT subsystem.
lslicense
Displays the number of fixed licenses and the status of floating licensing.
lslpp -l List all installed software
lslv
List configuration details of a given Logical Volume

-l List further configuration details of a given disk
lsprtsv -ch Shows print service information stored in the database.
lsps -a List pagaing space
lspv None List configured disks


List configuration details of a given disk

-l List Logical Volumes/Filesystems on a given disk
lsque
Displays the queue stanza name.
lsquedev
Displays the device stanza name.
lssrc -a List all subsystems
lsuser
Displays attributes of user accounts.
lsvfs
Lists entries in the /etc/vfs file.
lsvg None List configured Volume groups


List configuration details of a given Volume group

-l List Logical Volumes/Filesystems on a given Volume Group
mkcatdefs
Preprocesses a message source file.
mkdev
Adds a device to the system.
mkfont
Adds the font code associated with a display to the system.
mkfontdir
Creates a fonts.dir file from a directory of font files.
mkgroup
Creates a new group.
mkitab
Makes records in the /etc/inittab file.
mklv -y

Create a Logical Volume
mklv
Creates a logical volume.
mklvcopy
Adds copies to a logical volume.
mknamsv
Configures TCP/IP-based name service on a host for a client.
mknotify
Adds a notify method definition to the notify object class.
mkprtsv
Configures TCP/IP-based print service on a host.
mkps
Add an additional paging space to the system.
mkque
Adds a printer queue to the system.
mkquedev
Adds a printer queue device to the system.
mkserver
Adds a subserver definition to the subserver object class.
mkssys
Adds a subsystem definition to the subsystem object class.
mksysb.
Backs up mounted file systems in the rootvg volume group for subsequent reinstallation
mkszfile.
Records size of mounted file systems in the rootvg volume group for reinstallation
mktcpip
Sets the required values for starting TCP/IP on a host.
mkuser
Creates a new user account.
mkuser.sys
Customizes a new user account.
Mkvg -y

-s

Create a Volume Group on hdisk x
mkvg
Creates a volume group.
mkvirprt
Makes a virtual printer.
odmadd
Adds objects to created object classes.
odmchange
Changes the contents of a selected object in the specified object class.
odmcreate
Produces the .c (source and .h (include files necessary for ODM application development and creates empty objectclasses.
odmdelete
Deletes selected objects from a specified object class.
odmdrop
Removes an object class.
odmget
Retrieves objects from the specified object classes and places them into an odmadd input file.
odmshow
Displays an object class definition on the screen.
pwdck
Verifies the correctness of local authentication information.
redefinevg
Redefines the set of physical volumes of the given volume group in the device configuration database.
reducevg
Removes physical volumes from a volume group. When all physical volumes are removed from the volume group, the volume group is deleted.
reorgvg
Reorganizes the physical partition allocation for a volume group.
restbase
Restores customized information from the boot image.
rmdel
Removes a delta from a Source Code Control System (SCCS file.
rmdev
Removes a device from the system.
rmf
Removes folders and the messages they contain.
rmfs
Removes a file system.
rmgroup
Removes a group.
rmitab
Removes records in the /etc/inittab file.
rmlv
Removes logical volumes from a volume group.
rmlvcopy
Removes copies from a logical volume.
rmm
Removes messages.
rmnamsv
Unconfigures TCP/IP-based name service on a host.
rmnotify
Removes a notify method definition from the notify object class.
rmprtsv
Unconfigures a print service on a client or server machine.
rmps
Removes a paging space from the system.
rmque
Removes a printer queue from the system.
rmquedev
Removes a printer or plotter queue device from the system.
rmserver
Removes a subserver definition from the subserver object class.
rmssys
Removes a subsystem definition from the subsystem object class.
rmuser
Removes a user account.
rmvfs
Removes entries in the /etc/vfs file.
rmvirprt
Removes a virtual printer.
runcat
Pipes the output data from the mkcatdefs command to the gencat command.
savebase
Saves base customized device data in the ODM onto the boot device.
startsrc -s Start a subsystem
stopsrc -s Stop a subsystem
syncvg
Synchronizes logical volume copies that are not current.
usrck
Verifies the correctness of a user definition.
varyoffvg
Takes a Volume Group offline
varyoffvg
Deactivates a volume group.
varyonvg
Puts a Volume Group online
varyonvg
Activates a volume group.

0 comments: